Le modeste blog de Fstyle
Signaler

Bonjour cher lecteur, l'heure est grave !

Bon en fait non pas vraiment, mais j'ai un problème avec mon blog qui m'embète un peu. Son affichage est complètement buggé sous Internet Explorer. Perso j'utilise Firefox et je n'avais jamais fait gaffe, mais un pote qui du boulot (le fourbe) consulte de temps à autres mon blog m'a fait part du souci. En effet, par exemple en ce moment sous IE ça ressemble à ça :

Posts qui s'entremelent, post qui ne s'affiche pas, la pub non plus, fond en vrac, c'est tout cassé quoi... alors que sous Firefox ça donne normalement ceci :

J'avoue que je comprends pas d'où vient le souci, j'ai consulté pas mal de blogs sous IE et tous semblent ne présenter aucun problème et être aussi nickels que sous FF... donc ça vient probablement de moi, mais de quoi ? Certains posts semblent fonctionner, et d'autres non, alors qu'ils me semblent contruits de la même façon. J'suis un peu perdu !

Si vous avez une idée ? Je vous en remercie d'avance !

 

Edit : grace aux parfaits gentlemen que sont entres autres Sirocco, Lushlife et Mikadotwix et leurs conseils et  observations avisés, j'ai pu, me semble t'il, palier au moins en partie au problème.

En effet, en général quand je poste quelque chose, je tape le texte sous word, relax, puis je copie-colle directement dans l'interface de saisie de texte de blog. C'est en fait ce qui semble poser problème, car du code qui n'a visiblement rien à faire là s'immisce discretos au truc et met au final la pagaille (pardonnez mes approximations...).

Voilà en gros ce qu'on voit donc dans l'éditeur html de l'interface de blog :

Mon texte commence en fait en "noir", ce qui est surligné en bleu est le code "foireux" du au copier-coller en provenance de word. Et en effet, sur tous mes posts qui posaient problème sous internet explorer, ce genre de code était présent. Et ma foi rien qu'en le supprimant, ça semble déjà marcher carrément mieux.

Lushlife nous propose cette solution pour éviter, à la base, ce genre de désagrement :

(Je reformule vaguement la chose)

Commencer par copier-coller le texte issu de word dans l'éditeur html de l'interface blog. Cela donne un texte "d'un bloc". Il suffit ensuite de le mettre en forme via les outils de l'interface blog, de ce fait le "code" devrait être plus clean, et le post ne pas présenter de problème sur les navigateurs un peu capricieux.

Bref, un grand merci !

Ajouter à mes favoris Commenter (7)

Commentaires

Fstyle
Signaler
Fstyle
Merci à tous, ça semble fonctionner bien mieux maintenant. J'avais déjà tenté le bouton "nettoyer le code", mais je n'ai pas constaté d'effet, le mal était peut-être trop profond, où alors je m'y prenais comme une buse :P.
Merci pour la clarification Lushlife ! Je suivrai cette procédure désormais, je me suis permis d'éditer mon post et d'y inclure ton conseil.
Mikadotwix
Signaler
Mikadotwix
Pareil, je fais mes post sur Word.
Je fais un copier/coller, ensuite je clique sur l'option "nettoyer le code" (le gros pinceau jaune).
Et puis globalement faut simplement suprimer IE de tous les ordi (mais ça c'est un autre débat)
Lushlife_
Signaler
Lushlife_

Passer "par le tableau HTML pour éviter de ramasser tout le code foireux", ouille, tu pourrais me dire vaguement comment ? Je ne vois pas trop là.
Enfin déjà un très très gros merci à vous, je crois que du coup j'ai pu vaguement localiser via l'éditeur html du code "venant de word" qui se trouvait au tout début de mes posts et qui contribuait à tout foutre en l'air... en le supprimant ça a déjà l'air de fonctionner beaucoup mieux qu'avant sous IE !


Ben tu copies/colles dans l'éditeur HTML au lieu de le faire dans l'encart texte. :)
Fstyle
Signaler
Fstyle
Passer "par le tableau HTML pour éviter de ramasser tout le code foireux", ouille, tu pourrais me dire vaguement comment ? Je ne vois pas trop là.
Enfin déjà un très très gros merci à vous, je crois que du coup j'ai pu vaguement localiser via l'éditeur html du code "venant de word" qui se trouvait au tout début de mes posts et qui contribuait à tout foutre en l'air... en le supprimant ça a déjà l'air de fonctionner beaucoup mieux qu'avant sous IE !
Lushlife_
Signaler
Lushlife_
Si tu veux copier/coller du Word, passe par le tableau HTML pour éviter de ramasser tout le code foireux non pris en charge par l'éditeur. Ensuite, tout apparaîtra en bloc et à toi de refaire la mise en page selon ton plan de départ...
Fstyle
Signaler
Fstyle
En effet quand c'est un post plutôt long je fais ça sous word avec une mise en forme basique, puis je copie-colle, et ensuite je met le tout en forme via l'interface de blog. C'est peut-être une piste, merci ! Après pour ce qui est du code j'suis largué total, je n'y pige rien :P
Sirocco
Signaler
Sirocco
C'est de la merde IE !
C'est peut-être parce-que tu copies ton texte depuis Office, ça me fait le même problème...

Faut nettoyer le code, après...

Le modeste blog de Fstyle

Par Fstyle Blog créé le 09/07/10 Mis à jour le 16/08/12 à 13h24

Un blog peu mis à jour dernièrement... arg !

Ajouter aux favoris

Édito

Bienvenue cher visiteur ! Je suis Fstyle ou Fab pour les intimes, merci de votre visite.

Let's go !

Archives

Favoris